Article: SSL 38 Error when Launching Applications via Citrix NetScaler

[NOTE: I recently ran into this issue and the webinterface.conf changes mentioned in this Citrix forum post solved my issue. I’m also re-posting a Citrix article that covers the same problem.]

SSL 38 Error is Displayed when Launching Applications

Document ID: CTX128812   /   Created On: Apr 26, 2011   /   Updated On: Aug 24, 2011
Average Rating: not yet rated

Symptom

When trying to launch an application using ICA Proxy to XenApp via Access Gateway Enterprise the following error message is displayed:

Cause

Cause 1

This is possibly because of licensing restrictions as indicated in the article CTX119980 – SSL Error 38 when Launching Applications using Access Gateway Enterprise Edition

Cause 2

This issue can also be because of problems with Domain Name System (DNS) name resolution. When launching an application, the Access Gateway Enterprise Edition appliance uses the method specified in the WebInterface.conf file for name resolution. The Web Interface generates the ICA file. If the WebInterface.conf file is set to dns-port and DNS resolution is not possible, either because no DNS server is specified in the Access Gateway Enterprise configuration or the appliance being in a DMZ where no DNS server is reachable, then the launch of the application fails with the preceding error message.

Resolution

Option 1

The first option to resolve this issue is to specify a DNS server in the Access Gateway Enterprise Edition appliance within the Name Servers pane as shown in the following screenshot:

Option 2

The second option is to edit the WebInterface.conf file on the Web Interface server for that site, to resolve through ipv4-port rather than dns-port. The default location of the WebInterface.conf file is C:\inetpub\wwwroot\Citrix\sitename\conf\. Replace the sitename with the name of your site; the default sitename for a Web site on Web Interface is /Citrix/Xenapp. The following screenshots are sample screenshots of the WebInterface.conf file:

Before

After

Restart the IIS Web Server after saving the WebInterface.conf file.

This document applies to:

Thanks,
Alain

Advertisements

2 thoughts on “Article: SSL 38 Error when Launching Applications via Citrix NetScaler”

  1. Alain,
    Were you getting this error consistently on the client or random? I have this issue on thin clients but it doesn’t happen everytime. I checked my Netscaler and DNS is configured correct and is showing up on the server.

    1. LaCretia,

      It was inconsistent and was only happening for external connections and internla browser connections. Our thin clients were directly connecting to the web interface services site. Have you tried bypassing the NetScaler to see if the issue still occurs?

      Thanks for reading,
      Alain

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s